Important update on older versions of Modo with login-based licensing

Foundry, the team behind Modo, have announced that they are no longer supporting older versions of the OpenSSL libraries. This means customers with existing login-based maintenance licenses for Modo versions 10.2 to 14.0 will no longer be able to connect and activate a login-based license from June 30th.

Who does this affect?

Customers with a login based license with maintenance that lapsed prior to October 2nd 2020. RLM licenses are unaffected. 

What happens next?

Foundry will be updating the maintenance date on login-based customer’s entitlements to October 2nd 2020 so that licenses are compatible with Modo 14.1. 

Is a new license required?

No new license will be sent for this. The update will be done on Foundry’s side behind the scenes. 

When will this happen?

This license update has not yet taken place but will be completed on 30th of June. In the meantime, customers should be able to run current builds as normal.


If you’ve got any further enquiries about this update, this article on Foundry’s website provides all of the information. 

Comments are closed.